knrt.net
当前位置:首页 >> 如何将UBuntu下PHP5.5.9降为PHP5.4.39 >>

如何将UBuntu下PHP5.5.9降为PHP5.4.39

进入php源程序目录中的ext目录中,这里存放着各个扩展模块的源代码,选择你需要的模块,比如curl模块:cd curl执行phpize生成编译文件!phpize在PHP安装目录的bin目录/usr/local/php5/bin/phpize运行时,可能会报错:Cannot find autoconf.

到www.php.net下载php5.4源码,编译一个php5.4.然后把/usr/bin/php删除,重建(ln -s )指向编译好的php路径

直接卸载php5.5,重装php5.2

卸了!重装

重新下载php5.3的源码,然后编译时的prefix指向另一个目录,编译完后再更改下服务器的配置文件 ,把原来的关于php路径的配置更注释掉,然后将新的配置写进去,重启下服务器就可以了,后面还可以通过注释的方式在版本之间进行切换

如果你用的是apt-get安装的话,php的版本就是软件中心配置好了的,这个你就没法决定安装版本.如果你想安装指定版本的话,就只有到官网去下载源码,然后自己编译安装了

sudo apt-get install -y language-pack-en-base sudo LC_ALL=en_US.UTF-8 add-apt-repository ppa:ondrej/php sudo add-apt-repository ppa:ondrej/php sudo apt-get update apt-cache search php5 sudo apt-get install php5.5-common sudo apt-get install libapache2-mod-php5.5

1. 清除旧版本# Remove Ubuntu PHP Packagessudo apt-get remove php5 php5-cli php5-common php5-curl php5-dev php5-gd php5-geoip php5-imagick php5-intl php5-mcrypt php5-mysql php5-xdebug php5-xsl # Remove PECL Packagessudo

由于ubuntu 11.0.4默认安装的php版本 > 5.3,所以迫于无奈给自己的PHP降级了回到了远古的 php 5.2.6配合 zendoptiom的需要升级非常简单,/etc/apt/source.list中的gutsy替换为hardy,然后aptitude update、aptitude safe-upgrade、aptitude dist-

安装PHP5sudo apt-get install php7.0 php7.0-cli php7.0-fpm php7.0-gd php7.0-json php7.0-mysql php7.0-readline php7.0-xml php7.0-mbstring php7.0-curl安装后自动启动修改NGINX的配置文件,PHP解析部分更改为:location ~ \.php$ {try_files $

相关文档
网站首页 | 网站地图
All rights reserved Powered by www.knrt.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com