knrt.net
当前位置:首页 >> 怎样配置PHP让它支持mysql? >>

怎样配置PHP让它支持mysql?

不一定要独立配置,可以安装集成包,例如 xamp,wamp,phpstudy,PHP都能支持mysql,最重要的是PHP是可以直接操作MySQL的,使用mysqli扩展函数即可

1.在PHP安装目录下找到 PHP.INI 文件 使用记事本打开它2.使用查找 CTRL+F 找到;extension=php_mysql.dll 将前面的 ';'去掉改为 extension=php_mysql.dll 这样一来它就支持MYSQL数据库了!

我不支持下载安装版的,APACHE、PHP、MYSQL其实都可以下载ZIP版的,自己找个文件夹(比如D:\WWW)分别建三个目录,解压这些软件就可以用,解压以后需要做少数操作:APACHE,如果你希望机器开机自动运行,需要运行apache.

百度一下phpStudy PhpStudy是一个PHP调试环境的程序集成包 集成最新的Apache+PHP+MySQL+phpMyAdmin+ZendOptimizer,一次性安装,无须配置即可使用,非常方便、好用的PHP调试环境.该程序不仅包括PHP调试环境,还包括了开发工具、开发手册等.总之学习PHP只需一个包.

可能php.ini中的extension_dir指向的目录不正确,你先查找php_mysql.dll在哪个目录.然后把那个目录写在extension_dir=""的分号中.还有你那个语句可以改为$link=@mysql_connect("localhost","root","admin") or die ("fail");

再写一句extension=libmysql.dll,然后重启Apache,应该就可以了!

传个php文件上去啊 建议传个php探针文件上去 或者新建一个phpinfo文件代码如下?>保存 然后在浏览器访问 如果支持php的话 会有内容输出 支持mysql的话 下面有成功加载mysql模块的

1、下载phpstudy软件包,双击运行这个phpstudy软件包.在“安装-phpstudy 绿色集成环境”对话框里点击“下一步”按钮.2、在“安装-phpstudy 绿色集成环境”对话框里请“选择目标位置”,如默认安装,请直接点击“下一步”按钮.3、

有一个小软件叫 phpopt4iis ,通过它,在电脑上简单的点下一步安装一下,iis就可以支持php了,版本是由这个软件的版本来定,现在是php5,你也可以下载php4版本的. 另外一个比较麻烦的就是,你下载php包,然后在iis中,使用isapi添加

若要让php支持mysql和gd库等组件,需对php.ini进行配置 首先将php.ini-development 改为php.ini php.ini配置:将 ;extension_dir = "ext" 更改为:extension_dir = "C:\PHP\ext"并将前面的分号去掉,以设置php所支持组件的路径.将下了代

网站首页 | 网站地图
All rights reserved Powered by www.knrt.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com